BAQUIA

Linux también tiene problemas de seguridad

Recientemente, Yahoo News advertía de que existe un alto grado de vulnerabilidad en el Kernel 2,4 de Linux. Al parecer, este error permite a usuarios de una máquina Linux conseguir privilegios de acceso sin límite.

El problema es especialmente grave por la tranquilidad, anterior a esta noticia, con la que la comunidad Linux manejaba estos aspectos de seguridad en comparación con productos comerciales de los fabricantes más conocidos. El problema afecta al kernel de Linux anterior a la versión 2.4.23, que es la que lo corrige. Este fue el camino utilizado por piratas informáticos en un reciente ataque a una serie de servidores Debian. En dicho ataque, se vieron afectados 4 servidores Linux.

Linus Torvald, el creador de Linux, declaró en una entrevista vía e-mail que esta vulnerabilidad sólo podía ser explotada por alguien que tuviera acceso y dispusiera de una cuenta de usuario en el servidor y que no afecta a los usuarios de todos los sistemas Linux.

La ventaja, al parecer, es que no se puede activar desde fuera y que se trata de ataques internos en cualquier caso. Para la mayoría de los usuarios, para que se convirtiera en una seria amenaza, tendría que existir una cuenta hackeada y que ésta utilizara el error para ampliar sus privilegios como usuario.

En cualquier caso, aunque no todos los sistemas están afectados, Linus aconseja a todos los usuarios de versiones anteriores a la mencionada 2.4.23 que se pongan en contacto con sus distribuidores y averigüen si tienen ya la corrección para dicho problema.

Fue Andrew Morton, desarrollador del kernel de Linux, quien, en septiembre pasado, descubrió el fallo que ha sido corregido en la versión 2.4.23 de Linux. Al parecer, existía la corrección al problema, pero no todos los distribuidores habían recibido y/o implementado las correcciones .

También en Baquía:


Compartir en :


Noticias relacionadas

Recomendamos




Comentarios